Automatic Limit Bandwidth Perangkat Smartphone di Mikrotik

In Mikrotik by LikoElekLeave a Comment

Sebagai administrator jaringan tentunya kita harus bisa memanage bandiwth yang tersedia supaya trafik data bisa berjalan dengan lancar.

Nah, perkembangan jaman sekarang banyak orang yang memiliki smartphone, bahkan 1 orang bisa memiliki lebih dari 1 smartphone.

Jika semua smartphone tersebut terkoneksi ke jaringan maka akan mengakibatkan trafik jaringan yang padat.

Ada beberapa cara untuk mengatasi hal ini, salah satunya adalah dengan membatasi kecepatan internet pada perangkat smartphone melalui mikrotik.

Berikut adalah caranya.

Buatlah script seperti di bawah ini pada mikrotik dan jalankan script ini setiap 10 menit sekali.

:local hostip
:local list
:local testvalue

/system logging disable 0

/ip firewall address-list remove [find list~"smartphone-ip"]
:delay 1

:foreach i in=[/ip dhcp-server lease find where (host-name~"android" || host-name~"iPhone" || host-name~"Redmi" || host-name~"Galaxy")] do={	
	:local hostIPlist [/ip dhcp-server lease get $i value-name=address]
                              /ip firewall address-list add address=$hostIPlist list="smartphone-ip"
}       

/queue simple remove [find name~"Smartphone"]

:foreach i in=[/ip firewall address-list find] do={
	:set list ([/ip firewall address-list get $i list] )
	:set hostip ([/ip firewall address-list get $i address] )
	:set testvalue [/queue simple find name=$hostip]
	:if ([:len $testvalue] <= 0) do={
		:if ($list = "smartphone-ip") do={
			/queue simple add name="Smartphone $hostip" target=$hostip max-limit=0/896k
        	} 
        } 
}

/system logging enable 0

Jika berhasil maka perangkat Smartphone akan terlimit kecepatannya sebesar 896 kbps, ubahlah sesuai dengan kebutuhan di tempat anda.

Kelemahan dari script diatas adalah jika smartphone tersebut di root / jail break dan nama perangkatnya diganti, maka script diatas tidak mampu menangkap smartphone tersebut.

Smartphone yang bisa ditangkap oleh script ini adalah perangkat yang memiliki nama Android, iPhone, Redmi (xiaomi), dan Samsung Galaxy series. Anda bisa menambahkan nama – nama perangkat sesuai kebutuhan.

Comment With Facebook

or Reply with Wordpress

avatar

This site uses Akismet to reduce spam. Learn how your comment data is processed.

  Subscribe  
Notify of